Go to main site 3dtek.xyz

Y/A stepper motor issues


#1

I’ve recently finished putting together an xyz carve, however having some issues getting the Y axis to work. If I jogged it in the one direction it was OK, but if I changed direction, the A motor would still go the same direction it was going previously. The next jog after that in the new direction worked OK though, seems like it was just the first attempt in the new direction would go the wrong way. I wired the motors up per the instructions (black and green reversed on the A motor)

After being unable to work out what was happening, I removed the belts from the Y and A motors so I could troubleshoot. Now I was seeing all sorts of weird behavior from the A motor, it would sometimes turn the right way, sometimes the wrong way, but mostly just wobble a bit and not really turn at all. To test if the A motor was faulty I swapped the drivers for the Y and A motors, now the A motor worked fine and the Y motor was playing up, so seemed like an issue with the A driver. Then I swapped them back, and now both the Y and A motor are playing up, so now I’m not sure what’s happening.

I’ve tried adjusting the pots, but can’t seem to get them in any config that works. I can turn them all the way anti-clockwise and no LEDs come on for thermal shutdown which seems weird. Also the motors get very hot to the touch - not sure if this is normal or not.

I’ve checked the wiring pairs on the motor - as the cables are built in to the motor I can’t check the motor end, but I’ve done the test where you touch the pairs together and the motor gets hard to spin, so appears the wires are set correctly.

I’ve also checked that the switches for the microsteps and the A direction/steps are configured correctly.

It’s probably not related but the JP7 jumper was missing on my board - I’ve put a spare jumper I found on it. That is for Z axis though so shouldn’t have any effect anyway.

Any ideas? I’m wondering if there’s something weird going on with the grblaio board. Should I update the firmware or is this unlikely to fix the issue anyway?


#2

Just to add - I’ve done some further testing. It does seem (for the time being anyway) that whichever motor I plug in to Y works, and whichever motor I plug into A doesn’t. So it appears the motors themselves are fine, and it’s something to do with the A driver that’s playing up.

Firmware is 1.1f.20170324 which I believe is fairly current. Is this likely to be a problem with the AIO ?


#3

G’day
Wobbling or indecision regarding the direction is always motor wiring.
Generally one pair is not connected or the cabling has a break in it.

Connect a multimeter to the green black and measure resistance, do it again with red and blue. You will find that one of them has no resistance while the other has around 1 to 1.5 ohms.

Do this at the green plug end with the green plug disconnected form the AIO board to find out which pair is not connected correctly, then do it again at the motor plug end to see if the issue is in the motor or in the cable routed through the machine.

Please report back your findings here and also shoot an email to support
Cheers


#4

Thanks for getting back to me. I’ll see if I can track down a multimeter and get back to you with the results. It seems weird that if I plug the green plug (still connected to the same motor) into one of the other drivers it works fine, as if the connection failure is in the board itself rather than the wire. But I should have a better idea once I track down a multimeter.


#5

Well its true that the connection could be on the board, one of the 4 motor lines is not connected properly to the green socket.
Would you rather send the board back for us to test or replace?


#6

I’ve tested with a multimeter and I’m getting around 4.5 on each pair, measured at the green plug end. I’ve unplugged everything from the board and removed it from the case and I think there’s some pins not connected on the back - I’ll send you a photo.