Go to main site 3dtek.xyz

couple problems


#1

Hello today I use for first time my new GRBLAIO and I have a couple problems
Firs the software (version 2.0) start in mode alarm (I use $x for now) but what happens, I don’t use limit Switch.
Second the Z direction is all the time negative, no matter click the Z + or Z- button


#2

It starts in alarm mode if you have homing enabled. This is intentional because it wants you to know that it has no idea where it is in relation to home as the machine has just been turned on.
Your options are to home, $H, or to clear the error $X. Using $X is like saying “yes I know I should home it but I don’t want to right now just give me control”
If Z direction does not change it could be a) the Dir signal is not getting through to your Z driver or b) one pair of your two pairs of wire to the Z motor is not connected properly.
Are you using the external drivers or the onboard DRV8825 drivers?


#3

I already solved that was just a bad connection


#4

but now I have some worse problems
I work with aspire and nothing works, when I start a job in the lower corner the machine starts work in Y- I start at a higher corner and solve that, but in 3d and Vtool does not respect the depth z, only works correctly in 2d profiling.
I save the paths in *Gcode and *tap files
The machine worked before only it was very slow
Any idea what the problem is?
I’m totally lost
I leave a picture of my configuration


#5

Any answer???


#6

These machines always work in the negative space. VCarve and others will allow you to choose a stock box point and co ordinate system to match this setup. Alternatively there is a compile time option in grbl to change the system to use positive space.
There is no attached photo.
Z depth issues are usually missed steps due to lack of power to the z motor or to aggressive an acceleleration rate. First try to reduce z acceleration to 30mm/s/s


#7

$0 = 3 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 0 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 1 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 0 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 25.000 (Homing locate feed rate, mm/min)
$25 = 750.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 3.000 (Homing switch pull-off distance, millimeters)
$30 = 24000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 320.000 (X-axis travel resolution, step/mm)
$101 = 320.000 (Y-axis travel resolution, step/mm)
$102 = 320.000 (Z-axis travel resolution, step/mm)
$110 = 1000.000 (X-axis maximum rate, mm/min)
$111 = 1000.000 (Y-axis maximum rate, mm/min)
$112 = 1000.000 (Z-axis maximum rate, mm/min)
$120 = 500.000 (X-axis acceleration, mm/sec^2)
$121 = 500.000 (Y-axis acceleration, mm/sec^2)
$122 = 50.000 (Z-axis acceleration, mm/sec^2)
$130 = 740.000 (X-axis maximum travel, millimeters)
$131 = 790.000 (Y-axis maximum travel, millimeters)
$132 = 100.000 (Z-axis maximum travel, millimeters)


#8

solve a couple of problems but the machine is not reading my code.
It only works when I send you very basic code, like a square
What is the correct file to save my work?


#9

the z motor did not work well and I solved it by Z Micro step M0 / M1 / M2, in On On Off.


#10

I still have the same problems, some works well and others do not. I thought maybe it was my steppers motors but the machine lose the point exactly in the same place of the job again and again you lose the point Z.
I dont know what happens


#11

$0 = 3 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 0 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 1 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 0 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 25.000 (Homing locate feed rate, mm/min)
$25 = 750.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 3.000 (Homing switch pull-off distance, millimeters)
$30 = 24000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 320.000 (X-axis travel resolution, step/mm)
$101 = 320.000 (Y-axis travel resolution, step/mm)
$102 = 320.000 (Z-axis travel resolution, step/mm)
$110 = 250.000 (X-axis maximum rate, mm/min)
$111 = 250.000 (Y-axis maximum rate, mm/min)
$112 = 250.000 (Z-axis maximum rate, mm/min)
$120 = 10.000 (X-axis acceleration, mm/sec^2)
$121 = 10.000 (Y-axis acceleration, mm/sec^2)
$122 = 10.000 (Z-axis acceleration, mm/sec^2)
$130 = 740.000 (X-axis maximum travel, millimeters)
$131 = 790.000 (Y-axis maximum travel, millimeters)
$132 = 100.000 (Z-axis maximum travel, millimeters)


#12

What is the correct file to save my work?
you must save out G Code, that has been post processed with a valid post processor. Please check that you are using the GRBL post processor


#13

Yes I’m using GRBL post processor before ask you with the same bad result,
my configuration is right?


#14

any idea?


#15

If your loosing z position at the same point of a job then it’s unlikely a motor or driver issue. Is it possible the line of gcode is being skipped due to a regular expression exception in your ugs program? Look in tools, options, ugs?


#16

In order to help further, we need a really good description of the actual problem. At what point does it occur, is it by the same amount, z is getting deeper or shallower. To answer about your settings, please advise what kind of machine your using, is it ballscrew driven? Are you using the onboard drivers or external drivers? Cheers


#17

Thanks Again
the machine does not work in jobs where the machine makes travel Y direction or diagonally, no problem if the machine moves in direction X + or -.
when it fails it always does it in negative Z or negative Y.
I’m using on board drivers and ball screw driven.
the machine is the typical 6040 aluminum frame.
the steppers motors are of very dubious quality, do you think that could be the problem?


#18

On Tuesday a friend will come home with 3 NEMA 23, could that help? or is it wasting time?


#19

Ok interesting. It could be so many things.

*One thing we have noticed with the 6040 style machines is the power supplies are often very under powered. Sometimes as small as 100w. You really need at least 160w and preferably 250w. The under supply often shows when moving several axis at a time such as you have described.

  • also these machines are driving both sides of the gantry from a single centre screw, often on very under powered steppers. Have you checked to see how much power the y axis has. When the machine is powered up, how hard is it for you to over power the motor by dialing the knob on the front of the machine by hand. We have see many of these machines where almost no effort is required to move the machine this way and it’s usualy due to the size of the motor and not the size of the driver.

Negative z failures are more common as it takes more power to lift the z axis than to lower it so when there is a lack of power or an overly aggressive acceleration profile on the z it shows as losing positive direction steps and so digging deeper than it should. Please Test also how hard it is to over power the z motor by hand and report back. And also turn off the machine and see if it’s easy or difficult to wind it up by hand. It should not take much effort in the wrist or arm. Finger effort alone should be enough. If the z axis screw setup is misaligned or poor quality you might find it difficult to turn or there may be a tight spot somewhere along its travel. These tight spots can be responsible for z axis failures that happen repeatedly into the same spot of a job.

Have you watched the all in one card see if any of the error lights come on at any point. If an error light comes on even for a micro second it means that axis has lost steps due to driver shutdown.


#20

Good day Ben, The power supplies I have now is 24V 10A 250W next Tuesday one friend borrow me a power supplies 36V 10A 360W.

When the machine is powered up, how hard is it for you to over power the motor by dialing the knob on the front of the machine by hand

no much difficult

Please Test also how hard it is to over power the z motor by hand and report back.

no much difficult

And also turn off the machine and see if it’s easy or difficult to wind it up by hand. It should not take much effort in the wrist or arm.

Is easy and clean to wind it up by my hand in Z,X ans Y.
Move the Z motor is clean and very easy, that if the positive is much more difficult because the spindle is so heavy.

One thing to emphasize Driver current limiting I put them at low power because the steppers motors made noise and warmed up, not at least but not close to where the light comes on.
when it fails the lights never turn on.
I did a job connecting only the Z motor and the result is the same.
I remove the three motors of the machine and move the axes is very simple and clean.